Mettre à jour LibreOffice dernière version sous Debian

Écrit le 12 juin 2019  •  Intervention délicate •  10 min •  Aucun commentaire

Donc télécharger la dernière varsion de LibreOffice ici https://www.libreoffice.org/download (Linux x86-64 deb) → DOWNLOAD ainsi que :

  • Translated User Interface: français
  • Help for offline use: français

Puis, désinstaller la version installée, par exemple avec Synaptic → Rechercher "libreoffice6.3-ure" sélectionner et valider de tout désinstaller.

Lire la suite...

Mettre à jour Owncloud serveur de 10.0.7.2 à 10.0.8

Écrit le 12 mai 2018  •  Intervention délicate •  15 min •  Aucun commentaire

En fait, depuis plusieurs mises à jour de 10.0.x à 10.0.y les mises à jour automatiques par l'application interne de Owncloud s'interrompent en erreur autour de l'étape "Updating core". Le processus de mise à jour en reste là et le cloud n'est plus accessible.

Lire la suite...

Mettre à jour Joomla! de 3.7.5 à 3.8.0

Écrit le 25 septembre 2017  •  Intervention facile •  10 min •  Aucun commentaire

Après la mise à jour de Joomla! de 3.7.5 à 3.8.0 en passant par le Panneau d'administration → Composants → Mise à jour de Joomla! tout se passe bien. Sauf pour la mise à jour des Extensions qui obtient le message d'erreur "Le chemin de mise à jour n'existe pas". De 3.7.5 à 3.8.0 a priori mieux vaut commencer par mettre les extensions à jour, et ensuite seulement Joomla!. Et ça marche

Mettre à jour phpList 3.2.5 vers 3.3.1 et passer en HTTPS

Écrit le 27 mai 2017  •  Intervention délicate •  15 min •  Aucun commentaire

La procédure de mise à jour est illustrée ici : https://www.phplist.org/manual/ch031_upgrading.xhtml

Celle-ci fonctionne bien aussi : https://swip.pw/mettre-a-jour-phplist-de-3-2-1-a-3-2-4.html

Pour passer en HTTPS ajouter dans htdocs/config/config.php :

Lire la suite...

Mettre à jour Owncloud serveur de 9.0.8 à 9.1.0

Écrit le 09 février 2017  •  Modifié le 14 mars 2017  •  Intervention délicate •  15 min •  Aucun commentaire

    ./occ maintenance:mode --on
    cd ~/bases_de_donnees/
    mysqldump -ufoouserdb -pfoopwddb -hfoomysldb foodb > foo-908.sql
    cd -
    cd ..
    mv htdocs/ 908
    wget https://download.owncloud.org/community/owncloud-9.1.0.zip
    unzip owncloud-9.1.0.zip
    mv owncloud htdocs
    cp 908/config/config.php htdocs/config/
    cd htdocs/data/
    cp -r ../../908/data/foouser1 .
    cp -r ../../908/data/foouser2 .
    cd ..
    ./occ upgrade
    ./occ maintenance:mode --off
    cd ..
    rm owncloud-9.1.0.zip, et ça marche

Réinstaller DAVdroid pour synchoniser agenda et contacts depuis OwnCloud vers Android

Écrit le 02 janvier 2017  •  Rédaction en cours •  15 min •  Aucun commentaire

On veut mettre à jour la version libre et gratuite de DAVdroid (un adaptateur pour synchroniser CalDAV/CardDAV pour les appareils Android 4+). Donc on doit passer outre les boutiques en ligne d'achat/installation d'application. On veut néanmoins utiliser un fournisseur d'application le plus propre possible : https://f-droid.org.

Lire la suite...

Mettre à jour Joomla 3.5.1 à 3.6.2 et contourner le problème open_basedir

Écrit le 19 août 2016  •  Modifié le 20 août 2016  •  Intervention délicate •  17 min •  Aucun commentaire

00. Avant d'entamer la mise à jour de Joomla version 3.5.1 à version 3.6.2, quelques extensions demandent à être mises à jour également. La mise à jour d'une première extension produit une alerte :

Alerte
JFolder::create: Le chemin n'est pas dans les chemins open_basedir
Le chemin de mise à jour n'existe pas
Erreur
Unable to create destination
Message
COM_INSTALLER_TYPE_TYPE_ : erreur de mise à jour.

01. Editer le fichier folder.php qui se trouve dans libraries/joomla/filesystem

02. Rechercher et commenter la ligne $obd = ini_get('open_basedir');

03. Relancer la mise à jour des extensions.

04. Lancer la mise à jour de Joomla 3.5.1 → 3.6.0 → 3.6.2. Puis vérifier si il y a de nouvelles mise à jours pour les extensions, genre Joomla! Update Component ;)

05. Décommenter la ligne $obd = ini_get('open_basedir');

06. Vérifier et corriger si nécessaire la structure des tables, vider les caches, naviguer sur le site et checker les fonctionnalités comme le formulaire de contact, et ça marche

Mettre à jour Owncloud serveur de 8.2.7 à 9.1

Écrit le 10 août 2016  •  Modifié le 16 août 2017  •  Rédaction en cours •  300+ min •  Aucun commentaire

00. Suite à une mise à jour de Owncloud serveur, l'interface graphique Owncloud client ne semble plus fonctionner sous Debian. L'hypothèse est qu'il faudrait que les versions de Owncloud serveur et de Owncloud client soient comptatibles. A noter que Owncloud serveur ne supporte pas les mises à jour qui sauteraient une version majeure. En clair, impossible de passer de la version 8.2.7 à la version 9.1 sans passer par la version 9.0.

Contexte :

  • Owncloud serveur 8.2.7.
  • Owncloud client 1.7 sur Debian 8.5.
  • Documentation Owncloud en ligne ici pour la procédure d'upgrade manuelle.
  • Sauvegardes et backups et copies des fichiers et de la base de Owncloud serveur 8.2.7 !

Lire la suite...

Mettre à jour PluXml 5.4 vers 5.5

Écrit le 06 août 2016  •  Modifié le 08 août 2016  •  Intervention délicate •  7 min •  Aucun commentaire
  • IMPORTANT: Sauvegarder le dossier data de PluXml
  • Récuperer l'archive téléchargeable sur cette page et dézipper la à la racine du site de manière à écraser les fichiers existants.
  • Se connecter à l'administration du site et suivre la procédure de mise à jour affichée à l'écran, et ça marche
Fil RSS des articles de cette catégorie